Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Stale records causing deployment issue in Apigee Edge Cloud
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 14:36 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2023 - 11:25 PDT
Update
We are experiencing an issue with Apigee beginning on Thursday, 2023-06-22 03:18 US/Pacific.

Our engineering team continues to investigate the issue.

We apologize to all who are affected by the disruption.

Customers are not able to perform any deployment activities while using Apigee Edge Cloud
Posted Jun 22, 2023 - 08:40 PDT
Investigating
We are currently investigating this issue.
Posted Jun 22, 2023 - 08:17 PDT
This incident affected: API Services.