Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Edge Scheduled Release - Mon March 13, 2023
Incident Report for Apigee
Resolved
The incident has been resolved and the release notes can be viewed at http://apigee.com/docs/release-notes/content/apigee-edge-release-notes
Posted Mar 14, 2023 - 12:22 PDT
Update
We are continuing to investigate this issue & will post updates here.
Posted Mar 14, 2023 - 11:19 PDT
Update
No interruptions due to this issue. Release task is complete and the release notes can be viewed at http://apigee.com/docs/release-notes/content/apigee-edge-release-notes
Posted Mar 14, 2023 - 11:16 PDT
Investigating
We have an upcoming release window scheduled for Mon March 13, 2023. This release is not expected to cause any interruption to Apigee Edge UI.

Once the release is complete, release notes will be published at: http://apigee.com/docs/release-notes/content/apigee-edge-release-notes
Posted Mar 14, 2023 - 11:15 PDT
This incident affected: Management Services UI.