Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Edge UI, Management APIs, and login.apigee.com are experiencing latency
Incident Report for Apigee
Resolved
The issue has been resolved. We will continue to monitor to ensure services continue to function as expected. Thank you for your partnership and patience through this incident.
Posted 6 days ago. Jul 12, 2019 - 18:03 PDT
Identified
At this time, instrumentation services have been restored. Management API and UI functionality is working, and Runtime API transactions are processing normally. Technical teams are still actively working on full service and capacity restoration.
Posted 6 days ago. Jul 12, 2019 - 17:24 PDT
Update
We are continuing to work on service restoration. Additional updates will be posted here as they become available.
Posted 6 days ago. Jul 12, 2019 - 16:45 PDT
Update
We are continuing to work on service restoration. Additional updates will be posted here as they become available.
Posted 6 days ago. Jul 12, 2019 - 15:11 PDT
Investigating
We are actively investigating reports of latency with Edge UI, Management APIs and login.apigee.com.
Posted 6 days ago. Jul 12, 2019 - 13:04 PDT
This incident affected: Management Services UI, Management Services API, and Apigee Login and Single Sign-On.