Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Service Incident affecting the Developer Portal service
Incident Report for Apigee
Resolved
The incident was restored at 1:18 PM PDT and services continue to be stable. We apologize for any inconvenience this caused you. A full RCA is in flight to identify and track actions to prevent a future occurrence.
Posted Apr 23, 2024 - 16:23 PDT
Monitoring
The issue was identified and mitigating actions taken to restore services as of ~1:15pm PT. Our technical teams are continuing to monitor the service to ensure no further service disruptions while working to understand the root cause.
Posted Apr 23, 2024 - 13:34 PDT
Investigating
We are currently investigation an issue causing Developer Portals to not load. We'll provide updates as they become available. Thank you for your patience!
Posted Apr 23, 2024 - 13:16 PDT
This incident affected: Developer Services.