Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

API SSO Services Disruption
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted 30 days ago. Aug 21, 2019 - 00:41 PDT
Investigating
We are currently experiencing a disruption with API SSO Services. During this time, customers may experience SSO authentication failures when accessing Apigee services. Runtime services are not affected. We apologize for any impact this is causing and are working to restore services.
Posted 30 days ago. Aug 21, 2019 - 00:03 PDT
This incident affected: Apigee Login and Single Sign-On.