Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Management Services API & UI Latency
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted 18 days ago. Nov 01, 2018 - 06:12 PDT
Identified
The issue has been identified and the team is working on resolving it.
Posted 19 days ago. Oct 31, 2018 - 15:33 PDT
Investigating
We're experiencing an increase in latency on our Management Services API & UI and are looking into it. This is not impacting API runtime traffic.
Posted 19 days ago. Oct 31, 2018 - 15:32 PDT
This incident affected: Management Services UI and Management Services API.