Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Log4J CVE-2021-44228 Response Update
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Feb 16, 2023 - 09:33 PST
Update
Log4j v1.x:
We are aware of the recent upgrade to CVE-2021-4104 which affects versions of Log4j 1 which are used on Apigee Edge and OPDK. This CVE requires a specific configuration of Log4j 1 which Apigee Edge does not use and which Apigee OPDK does not ship as a default configuration.

User Supplied Log4j 1 Java Callouts
Apigee SaaS (X and Edge):
Customers can upload vulnerable configurations of Log4j 1 in their custom resources, but CVE-2021-4104 is mitigated due to Java Security Manager restrictions.

Apigee OPDK and Hybrid
Users should upgrade all of their custom resources of Log4j to the latest version.
Users can mitigate uploaded vulnerable versions of Log4j 1 in Hybrid and OPDK by enabling a custom java callout security policy:
Hybrid: https://cloud.google.com/apigee/docs/api-platform/develop/adding-custom-java-callout-security-policy
OPDK: https://docs.apigee.com/api-platform/reference/java-permission-reference
Posted Dec 17, 2021 - 10:40 PST
Monitoring
Updated December 15, 2021 15:22 PST

Google Apigee is actively following the security vulnerability in the open-source Apache “Log4j 2" utility (CVE-2021-44228 and CVE-2021-45046). We encourage you to update to the latest version of Log4j 2. We are currently assessing the potential impact of the vulnerability for Apigee products and services. This is an ongoing event and we will continue to provide updates through this page and our customer communications channels.

Background: The Apache Log4j 2 utility is a commonly used component for logging requests. On December 9, 2021, a vulnerability was reported that could allow a system running Apache Log4j 2 version 2.14.1 or below to be compromised and allow an attacker to execute arbitrary code.

On December 10, 2021, NIST published a critical Common Vulnerabilities and Exposure alert, CVE-2021-44228. More specifically, Java Naming Directory Interface (JNDI) features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from remote servers when message lookup substitution is enabled.

==== Platform ====

Apigee X:
Apigee X does not use Log4j 2.

Apigee Hybrid:
Current supported versions of Hybrid do not use Log4j 2.
Unsupported versions of Hybrid used Log4j 1.x, but it is not included in any of the currently supported versions. Customers on Hybrid 1.4 or lower are unaffected by this CVE but should still upgrade to a supported version.

Apigee Edge:
Apigee Edge’s default configuration contained Log4j 2 but was not vulnerable to Log4j 2 (CVE-2021-44228).

Apigee OPDK:
Apigee OPDK’s default configuration contained Log4j 2 but was not vulnerable to Log4j 2 (CVE-2021-44228).
The service “apigee-machinekey” includes Log4j 2 and does not process any user-provided input. It is not susceptible to the vulnerability CVE-2021-44228.


==== User Supplied Log4j 2 Instances ====


Apigee SaaS (X and Edge):
Customers can upload vulnerable versions of Log4j 2 in their custom resources, but CVE-2021-4228 is mitigated due to Java Security Manager restrictions.

Apigee Hybrid and OPDK:
Users can mitigate uploaded vulnerable versions of Log4j 2 in Hybrid and OPDK by enabling a custom java callout security policy:
Hybrid: https://cloud.google.com/apigee/docs/api-platform/develop/adding-custom-java-callout-security-policy
OPDK:
https://docs.apigee.com/api-platform/reference/java-permission-reference


==== Versions Updates ====

Log4j v1.x:
Apigee Edge and Apigee OPDK contain Log4j 1.x and Log4j 2.x libraries. Log4j 1 is not part of this particular assessment.
All instances of Log4j 1 will be upgraded across all Apigee products in upcoming releases to the latest version of Log4j 2. Upgrades to SaaS services and releases for OPDK are expected in January.

==== More Information ====

Information on this page is based on findings in our ongoing investigations.

Please see these helpful articles published to the Apigee Community:

How to Detect Network Probes on Traversing Your Apigee Proxies-
https://www.googlecloudcommunity.com/gc/Apigee/Detecting-Attempts-to-Exploit-Log4j-CVE-2021-44228-on-Apigee/td-p/178123

How To Mitigate Log4Jv2 Attacks CVE-2021-44228 Traversing Apigee Proxies -
https://www.googlecloudcommunity.com/gc/Apigee/How-To-Block-requests-that-exploit-Log4j-CVE-2021-44228-on/td-p/178138
Posted Dec 14, 2021 - 09:04 PST
This incident affected: API Services.