Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

API Services Disruption
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 06, 2019 - 21:53 PST
Investigating
We are currently experiencing a disruption with Management API Services in US East. During this time, customers may experience delays in their Management API response and/or increased error rates on the Edge UI. We apologize for any impact this is causing and are working to restore services.
Posted 7 months ago. Mar 06, 2019 - 21:22 PST
This incident affected: Management Services UI and Management Services API.