Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Upcoming maintenance of Apigee Edge infrastructure component
Scheduled for Aug 16, 17:00 - 20:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted 6 days ago. Aug 09, 2018 - 12:07 PDT
Scheduled
We have an upcoming maintenance on one of the central management components of Apigee Edge infrastructure scheduled to start Thursday, August 16, 2018 between 5:00 PM to 8:00 PM PST. This maintenance is not expected to cause any interruption to Apigee Edge.
Posted 7 days ago. Aug 08, 2018 - 16:58 PDT
This scheduled maintenance affects: Management Services UI and Management Services API.