Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Trial Organizations Returning 404 Responses
Incident Report for Apigee
Resolved
This issue has been resolved by technical teams.
Posted 18 days ago. Jun 28, 2018 - 10:59 PDT
Investigating
We are investigating reports of 404 responses from API calls to many Apigee Trial Organizations. We are actively investigating the issue.
Posted 18 days ago. Jun 28, 2018 - 07:29 PDT
This incident affected: Apigee Edge (Developer Edition).