Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Management UI for Apigee Hybrid services is experiencing Unavailability
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Oct 06, 2020 - 01:50 PDT
Investigating
The Apigee Management UI (https://apigee.google.com/edge) for Apigee Hybrid services is currently unavailable due to internal errors. We are currently investigating the issue and further updates will follow..
Posted Oct 06, 2020 - 01:35 PDT
This incident affected: Management Services UI.