Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Management Services and UI Latency
Incident Report for Apigee
Resolved
No further incidents were logged during the monitoring period. Marking this as resolved.
Posted about 18 hours ago. Dec 12, 2018 - 13:25 PST
Update
Monitoring activities are ongoing and will continue through the weekend to ensure service stability.
Posted 13 days ago. Nov 30, 2018 - 10:22 PST
Monitoring
Management API and UI (enterprise.apigee.com) service performance is back within normal limits. The Apigee team will continue to monitor this issue, and investigate the root issue for remediation. API runtime services were not impacted during the course of this incident.
Posted 14 days ago. Nov 29, 2018 - 12:20 PST
Identified
We've identified an issue contributing to the latency on our Management Services UI (enterprise.apigee.com) and carrying out a restoration plan. We'll provide an update after we've validated services post this action.
Posted 14 days ago. Nov 29, 2018 - 10:50 PST
Investigating
We're experiencing an increase in latency on our Management Services UI (enterprise.apigee.com) and are looking into it. This is not impacting API runtime traffic.
Posted 14 days ago. Nov 29, 2018 - 10:42 PST
This incident affected: Management Services UI and Management Services API.