Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee UI Disruption - EU Region
Incident Report for Apigee
Resolved
The UI Services have been restored for the affected EU region.
Posted 17 days ago. Nov 26, 2018 - 03:05 PST
Investigating
We're experiencing a disruption of certain Apigee UI services in the European region. Please switch to using the Apigee Classic UI as we actively investigate this issue. This is not impacting API runtime traffic.
Posted 17 days ago. Nov 26, 2018 - 01:06 PST
This incident affected: Management Services UI.