Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Intermittent failures creating Integrated Developer Portals
Incident Report for Apigee
Resolved
This issue is resolved, and all functionality restored.
Posted 8 days ago. Sep 11, 2019 - 11:40 PDT
Investigating
We are seeing intermittent failures creating Developer Portals in the Apigee Integrated UI. Apigee teams are actively working to identify and correct the problem.
Posted 8 days ago. Sep 11, 2019 - 10:42 PDT
This incident affected: Developer Portal (Integrated).