Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

API Services Disruption
Incident Report for Apigee
Postmortem

Final Incident Report Summary:

A DNS incident in the EU-West region resulted in an outage affecting API runtime, UI, and Management services. The root cause for the incident was determined to be an OS level bug which resulted in a kernel panic condition across both the Master and Slave DNS nodes. For services that cached DNS data locally with time-to-live (TTL) longer than the outage time period, services would have been unaffected. However, any services requiring DNS resolution during the outage would have failed. Full service restoration was reached after steps were carried out to manually provision and configure new DNS servers.

We apologize for this outage and are taking steps in priority to address recurrence and to improve service reliability. If you have any additional questions, please open a P3 Support case to Apigee Support and we’ll be happy to assist.

Posted 13 days ago. Jun 05, 2018 - 21:30 PDT

Resolved
This incident has been resolved.
Posted 17 days ago. Jun 01, 2018 - 11:15 PDT
Update
All services in the Apigee EU-West region have been fully restored. If you continue to see any service impact, please log a support ticket with Apigee Support.
Posted 18 days ago. May 31, 2018 - 17:26 PDT
Monitoring
Primary actions to restore services have been completed and are observing evidence of service recovery. We are in the process of validating full service restoration which includes evaluating the status of other dependent services. Customers in EU-West may continue to experience degraded service impact until service restoration is fully confirmed. Additional updates to follow.
Posted 18 days ago. May 31, 2018 - 12:52 PDT
Update
Apigee EU-West is experiencing a Management/Runtime outage. The current root cause is unclear at this point. We are investigating the errors and the root cause. All DN customer traffic should have failed over. We're working to confirm that to be the case. Single homed customers in EU-West will continue to experience service impact until the issue is resolved. We will provide updates on a regular basis via this status page.
Posted 18 days ago. May 31, 2018 - 11:10 PDT
Update
We are still in the process of implementing the fix to resolve this issue and will keep you posted on the progress shortly.
Posted 18 days ago. May 31, 2018 - 10:16 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 18 days ago. May 31, 2018 - 09:48 PDT
Update
We are continuing to investigate this issue.
Posted 18 days ago. May 31, 2018 - 09:31 PDT
Investigating
We are currently experiencing a disruption with API Services in EMEA (EU-West region only). During this time, customers may experience delays in their API response and/or increased error rates. We apologize for any impact this is causing and are working to restore services.
Posted 18 days ago. May 31, 2018 - 09:29 PDT
This incident affected: API Services, Management Services UI, and Management Services API.