Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Management Services and UI intermittent slowness
Incident Report for Apigee
Resolved
Issue has been resolved. We will continue to monitor to ensure services continue to function as expected. Thank you for your partnership and patience through this incident.
Posted 27 days ago. Jun 21, 2019 - 13:55 PDT
Investigating
We're investigating an issue causing intermittent increase in latency on our Management / UI services(enterprise.apigee.com). This is not impacting API runtime traffic. We will provide updates as they become available or as status changes.
Posted 27 days ago. Jun 21, 2019 - 11:00 PDT
This incident affected: Management Services UI and Management Services API.