Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Emergency API BaaS maintenance in us-west-2 - Wed Feb 21 2018
Incident Report for Apigee
Resolved
The scheduled maintenance has been completed
Posted Feb 21, 2018 - 12:58 PST
Monitoring
We have an emergency maintenance scheduled for Wed February 21 2018 starting 11:20 AM PST affecting part of us-west-2 (Oregon) region. This maintenance is not expected to cause any interruption to Apigee Edge - API BaaS.
Posted Feb 21, 2018 - 11:14 PST