Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Performance Degradation for API BaaS Services
Incident Report for Apigee
Resolved
The BaaS cluster is up and running and the concerned services have been restored. The performance degradation issue is resolved and back to normal.
Posted 2 months ago. Jun 09, 2018 - 01:38 PDT
Identified
We have identified the root cause to an infrastructure performance issue . Work is underway to scale up the cluster to address this. Customers will continue to see degraded performance until this is completed. Currently we have no ETA for resolution.

This is localized to the US-East region only.
Posted 2 months ago. Jun 08, 2018 - 09:35 PDT
Investigating
API BaaS is currently experiencing degraded performance. The issue seems to be localized to the US East region. However, we are checking if other regions are also affected.
Posted 2 months ago. Jun 08, 2018 - 00:28 PDT
This incident affected: API BaaS.