Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Management Services UI Latency
Incident Report for Apigee
Resolved
This incident has been resolved. This was related to the Emergency maintenance which was undertaken and completed.
Posted Nov 15, 2017 - 13:54 PST
Investigating
We are investigation new reports of UI slowness in EU-WEST region. Apigee personnel are actively working to correct this.
Posted Nov 14, 2017 - 07:37 PST
Monitoring
The issue with the Management Services and UI in US West has been addressed. We will monitor the situation for a few more hours.
Posted Nov 14, 2017 - 01:02 PST
Investigating
We're experiencing an increase in latency on our Management Services UI (enterprise.apigee.com) in the US West region and are looking into it. This is not impacting API runtime traffic.
Posted Nov 13, 2017 - 18:47 PST
This incident affected: Management Services UI and Management Services API.