Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Edge Management Services Degraded Performance
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Feb 24, 2017 - 09:03 PST
Identified
We're experiencing issues with Management Services/ UI (enterprise.apigee.com) and are looking into it. This is not impacting API runtime traffic.
Posted Feb 23, 2017 - 07:17 PST
This incident affected: Management Services UI and Management Services API.