Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Emergency API BaaS maintenance in us-east-1 and us-west-2 - Thu Feb 22 2018
Incident Report for Apigee
Resolved
The scheduled maintenance has been completed
Posted Feb 22, 2018 - 17:05 PST
Monitoring
We have an emergency maintenance scheduled for Thursday February 22 2018 starting 10:30 AM PST affecting part of us-east-1 (N. Virginia) and us-west-2 (Oregon) regions. This maintenance is not expected to cause any interruption to Apigee Edge - API BaaS.
Posted Feb 22, 2018 - 10:22 PST