Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Edge Management Services Degraded Performance
Incident Report for Apigee
Resolved
This issue has been resolved and we are currently monitoring this. Please reach out to the Support team if you do see this issue persist.
Posted Feb 22, 2017 - 09:50 PST
Investigating
We're experiencing issues with Management Services/ UI (enterprise.apigee.com) and are looking into it. This is not impacting API runtime traffic.
Posted Feb 22, 2017 - 08:49 PST
This incident affected: Management Services UI, Management Services API, and Developer Services.