Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

API Services disruption - US-East region
Incident Report for Apigee
Postmortem

Final Incident Report Summary:

A simultaneous failure of all active nodes in a tier of Apigee’s service in the US-East region (NAT gateway) created a primary impact to customer API traffic in the region. This prevented API requests to the Apigee service from connecting to customers’ target backend services, resulting in API failures. Corrective actions were then taken to restore traffic. However, subsequent automatic scaling processes that triggered as a result of the primary impact introduced unhealthy API message processor nodes into the system, which resulted in a secondary impact for some customers.

If you were impacted by this incident and would like a copy of the more detailed Incident Report, please open a P3 Support case to request.

Posted Nov 08, 2017 - 12:21 PST

Resolved
Apigee has been monitoring these services closely over the last 12 hours and services continue to operate as expected. The RCA process is in flight and a preliminary summary will be posted shortly with a full summary to follow once completed.
Posted Nov 08, 2017 - 12:19 PST
Monitoring
Services have been restored. The team will continue to monitor services closely over the next 24 hours. The outage stemmed from an issue impacting the NAT service in the East Region only. Services in other regions continued to work as expected. RCA is in flight and will track all follow-up activities to help prevent a recurrence of this outage. We sincerely apologize for any inconvenience caused by this incident and appreciate your patience through this process.
Posted Nov 07, 2017 - 20:17 PST
Update
The services are being restored. You may still experience some intermittent issues. We are working through them and will keep the page updated. Thanks for your patience.
Posted Nov 07, 2017 - 18:00 PST
Investigating
Apigee technical teams continue to investigate the issue. Services may be intermittently available during this time as we work to restore services. We will update the status with an ETA as soon as it's available.
Posted Nov 07, 2017 - 14:41 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 07, 2017 - 13:59 PST
Investigating
We are currently experiencing a disruption with API Services in the US-East region. During this time, customers may experience delays in their API response and/or increased error rates. We apologize for any impact this is causing and are working to restore services.
Posted Nov 07, 2017 - 12:37 PST
This incident affected: API Services and Management Services UI.