Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Management Services API and UI Errors
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 27, 2018 - 13:42 PDT
Monitoring
We have identified the issue and have taken corrective action. Root Cause Analysis and Mitigation are in progress.
Posted 3 months ago. Sep 27, 2018 - 11:41 PDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Sep 27, 2018 - 11:40 PDT
Investigating
We're experiencing an increase in errors on our Management Services UI (enterprise.apigee.com) and are looking into it. This is not impacting API runtime traffic.
Posted 3 months ago. Sep 27, 2018 - 10:55 PDT
This incident affected: Management Services UI and Management Services API.