Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee API BaaS critical maintenance in us-east-1, eu-west-1
Incident Report for Apigee
Resolved
The scheduled maintenance has been completed
Posted Mar 15, 2018 - 18:14 PDT
Investigating
We have a critical maintenance scheduled for Thursday, March 15 2018 starting 11:00 AM PDT affecting part of us-east-1 (N. Virginia) and eu-west-1 (Ireland) regions. This maintenance is not expected to cause any interruption to Apigee Edge - API BaaS.
Posted Mar 15, 2018 - 10:32 PDT