Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Monetization email notifications temporarily disabled.
Incident Report for Apigee
Resolved
An automated batch job has been created to deliver the notifications on an every-12-hour schedule.
Posted May 13, 2020 - 11:32 PDT
Monitoring
We've implemented a workaround to allow batch delivery of notifications. We're working on a permanent solution to ensure normal delivery of notifications.
Posted May 01, 2020 - 14:31 PDT
Update
We are continuing to investigate this issue.
Posted May 01, 2020 - 07:15 PDT
Update
A mitigation has been put in place to allow for partial email notifications to occur. We are still working towards a full resolution of monetization email notifications.
Posted May 01, 2020 - 07:15 PDT
Investigating
We are currently investigating an issue with monetization email notifications, and have subsequently disabled the email notification feature. There is no impact to live runtime traffic for any API services at this point.
Posted May 01, 2020 - 04:44 PDT
This incident affected: Developer Services.