Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Developer Portal outage for a few customer
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Aug 26, 2016 - 09:57 PDT
Identified
Pantheon - Apigee's Developer Portal provider is seeing a few customers affected. Please refer to this status page for further updates - http://status.pantheon.io/
Posted Aug 26, 2016 - 09:08 PDT