Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Edge UI login issues impacting some users
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Apr 24, 2018 - 20:36 PDT
Monitoring
We have identified the cause and fixed this. Users should be able to login to the UI page now. We will continue to monitor this until this issue is finally resolved.
Posted Apr 18, 2018 - 21:30 PDT
Investigating
We are actively investigating issues with Apigee Edge UI logins in APAC region. Will keep you updated on the progress.
Posted Apr 18, 2018 - 21:24 PDT
This incident affected: Management Services UI.