Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Management Services Disruption
Incident Report for Apigee
Resolved
Apigee Management Services are now restored across regions.
Posted Jun 23, 2017 - 03:00 PDT
Investigating
We are still experiencing intermittent failures in our Management Services and continue to work it on priority. This is unlikely to have an impact on API Runtime Traffic.

This is a continuation of the following incident : https://status.apigee.com/incidents/76mvmbqqmxsz
Posted Jun 23, 2017 - 00:51 PDT