Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Edge Emergency Release - Oct 9, 2014
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Oct 10, 2014 - 07:41 PDT
Investigating
We have an Emergency release scheduled for Oct 9,2014. This release is not expected to cause any interruption to Apigee Edge.
Posted Oct 09, 2014 - 21:36 PDT