Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Emergency Maintenance - UI - March 27, 2015
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Mar 27, 2015 - 03:02 PDT
Investigating
We are deploying an Emergency fix for Apigee UI. This will not impact any run time traffic.
Posted Mar 26, 2015 - 23:55 PDT