Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Apigee Edge Analytics/Reports Issues
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Mar 23, 2015 - 21:51 PDT
Identified
We're experiencing an issue where the Dashboard/Reports do not return any results (enterprise.apigee.com / edge.apigee.com) and are looking into it. This is not impacting API runtime traffic.
Posted Mar 23, 2015 - 15:40 PDT