Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Emergency maintenance fix starting 4:am PST Monday, Sept 1st, 2014
Incident Report for Apigee
Resolved
This incident has been resolved.
Posted Sep 01, 2014 - 04:50 PDT
Investigating
We are making an emergency change to Apigee Edge. During this time access to Management UI and Sign on will be disabled. All runtime traffic will not have any impact. We will keep you posted on progress.
Thanks,
Apigee Support
Posted Sep 01, 2014 - 03:50 PDT