Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

Saving API revision errors - API runtime traffic not impacted
Incident Report for Apigee
Resolved
This incident has now been resolved. All users should now be able to save API revisions.
Posted Aug 15, 2014 - 10:51 PDT
Investigating
We are experiencing a problem where users are getting errors when attempting to save a revision on Apigee Edge. Users may see the following error message: "saving revision failed and system could not recover". API runtime traffic is not impacted by this. We are working to resolve the issue as soon as possible.
Posted Aug 15, 2014 - 09:02 PDT