Apigee Release Schedule

Apigee Edge: Tue-Thu 12am to 4am in Singapore, Central European, and US Eastern time zones (learn more)

Read the release notes to learn what is new.

We are experiencing Issues with Apigee Analytics and are currently investigating
Incident Report for Apigee
Resolved
The issue identified with Apigee Analytics has been been resolved and the services have been restored.
Posted Aug 29, 2014 - 07:03 PDT
Investigating
We are currently investigating this issue.
Posted Aug 28, 2014 - 10:10 PDT